
 

 

i 

  

TopSolid'Wood  

Creation of a door 



  TopSolid'Wood: Creation of a door 

ii   Missler Software 

© 2015, Missler Software. 
7, Rue du Bois Sauvage 
F-91055 Evry, FRANCE 
Web: www.topsolid.com 
E-mail: info@topsolid.com 
All rights reserved. 
 
This information is subject to change without warning. 
No material may be reproduced or transmitted, regardless of the manner, electronic or mechanical means used 
or purpose, without formal written consent from Missler Software. 

TopSolid® is a registered trademark of Missler Software. 

TopSolid® is a product name of Missler Software. 

The information and the software contained within this document are subject to change without prior warning 
and should not be construed as a commitment by Missler Software. 

The software covered by this document is supplied under license, and may only be used and duplicated in 
compliance with the terms of this license. 

Version 6.16 Rev.01 

Note: If you are experiencing problems using this training guide, please feel free to send your feedback and 
comments at edition@topsolid.com. 

http://www.topsolid.com/
mailto:info@topsolid.com
mailto:edition@topsolid.com


TopSolid'Wood: Creation of a door   

Missler Software   iii 

Contents 

Creation of a hinge component ........................................................................................................................ 1 

Search for component's 3D files ............................................................................................................................... 1 

Creation of the hinge arm ......................................................................................................................................... 1 

Creation of the mounting plates ............................................................................................................................... 3 

Creation of the mounted hinge ................................................................................................................................ 6 

Creation of the door ....................................................................................................................................... 10 

Creation of the driver block component................................................................................................................. 10 

Creation of the door and the supporting sides ....................................................................................................... 11 

Insertion of the repeated hinges ............................................................................................................................ 12 

Insertion of an optional additional hinge ............................................................................................................... 13 

Definition of elements ............................................................................................................................................ 15 

Creation of door panel subcomponents .......................................................................................................... 16 

Creation of subcomponents ................................................................................................................................... 17 

Configuration of subcomponents ........................................................................................................................... 20 

Using the door ............................................................................................................................................... 21 

Notes ............................................................................................................................................................. 23 





TopSolid'Wood: Creation of a door  Creation of a hinge component 

Missler Software   1 

Creation of a hinge component 

Search for component's 3D files 

Hardware suppliers propose to provide the 3D geometries of their hardware parts. 
These 3D files can be opened and used in TopSolid'Wood, but to be used optimally 
these components must be made "intelligent" by assigning processes and key 
points to them. 
 
The Blum and Hettich supplier's hardware libraries can be installed via the 
TopSolid'Wood installation DVD. 

The hardware components can then be found by their part number. 

 From Windows Explorer, open the TopSolid'Wood's installation folder (generally C:\Missler). 

 Then open the following folders: V6x\z\woo\lib. 

- The Blum library can be found in the BLUM_HARDWARE folder. 
- The Hettich library can be found in the HETTICH_HARDWARE folder. 

 From the Windows Explorer's search bar, search for the part number of the hardware component. 

 

 Then open the .top file that appears by clicking and dragging it from Windows Explorer to TopSolid's graphics 
area. 

Creation of the hinge arm 

 Open the file called CLIP top#V=71t3590#I=00#R=NR.top. 

 Save this file in the My 3D Standard library : 

- New family: Hinges 
- New type: BLUM arm 
- New variant: Overlay door 110° 

 Define the set: 

- Designation: BLUM hinge arm overlay door 110° 
- Reference: 71t3590 
- Supplier: Blum 

 Make layer 1 current. 

 Define the document's absolute coordinate system as a key point using the Assembly > Define component > 

Define key points function, and then select the coordinate system.  
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 Create the rectangular sketch that will allow the extrusion of 
the supporting part. 

 When extruding the sketch, open the advanced parameters. 

 
 Then select the hinge's bottom support face as the shift origin 

face in order to extrude the part from this face. 

 Validate the parameters with OK and extrude the part to 
19mm. 

 
 
 
 
 
 

 On the supporting part, create two blind holes aligned on the 
drillings of the hinge's screws: 

- Diameter: 5mm 
- Depth: 12mm 
- Bottom angle: 0° 

 
 
 
 
 
 
 

 On the supporting part, create a blind hole aligned on the 
hinge: 

- Diameter: 35mm 
- Depth: 12mm 
- Bottom angle: 0° 

 
 
 
 
 
 

 Define these drillings as component tools: 

- Name of the tool element: tool1 
- Designation of the tool element: Arm drillings 

 Include the three created drillings in this tool. 

 Save and close the file. 
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Creation of the mounting plates 

Creation of the 0mm mounting plate 

 Open the file called CLIP#V=173l8100#I=00#R=NR.top. 

 Save this file in the My 3D Standard library : 

- Family: Hinges 
- New type: BLUM mounting plates 
- New variant: CLIP mounting plate 0mm 

 Define the set: 

- Designation: CLIP mounting plate 0mm 
- Reference: 173l8100 
- Supplier: Blum 

 Make layer 1 current. 
 

 Define the document's absolute coordinate system as a key point using the Assembly > Define component > 
Define key points function, and then select the coordinate system. 

 Create the supporting part from a sketch positioned on the support plane of the mounting plate. 

 

 On the supporting part, create two blind holes aligned on the drillings of the mounting plate's screws: 

- Diameter: 5mm 
- Depth: 12mm 
- Bottom angle: 0° 
 
 
 
 
 
 
 

 Then, define these drillings as component tools: 

- Name of the tool element: tool1 
- Designation of the tool element: Mounting plate drillings 

 Include the two created drillings in this tool. 
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Note: The goal is to create a hinge with two mounting plates of different thicknesses (0 and 3mm). 
As a result, when the mounting plate is exchanged with another one, the position of the hinge in thickness has to 
change. 
An auxiliary coordinate system will be created in each mounting plate model. This auxiliary element will then be 
used in the hinge assembly (mounting plate + arm) to create the hinge's positioning coordinate system. 
When the mounting plate is interchanged, the auxiliary coordinate system is also interchanged, and the key point 
and the hinge positioning will be adjusted accordingly. 

 Launch the Tools > Coordinate system > Wizard = Yes function. 

 Select the absolute coordinate system. 

Note: When selecting a coordinate system, the wizard will create a duplicate coordinate system. 
The six red arrows allow you to create a translated coordinate system, while the advanced options allow you to 
create another transformation. 

 Click on the Advanced options button.  

 Adjust the following parameters for the transformation: 

- Rotation 
- Axis: Y- 
- Rotation angle: 90° 

 Define the created coordinate system as an auxiliary element using the 
Assembly > Define component > Define auxiliary elements. 

- Name of the auxiliary element: cs1 
- Designation of the auxiliary element: Hinge positioning on the cabinet side 

 

 Save and close the file. 

Creation of the 3mm mounting plate 

 Open the file called CLIP#V=173l8130#I=00#R=NR.top. 

 Save this file in the My Standard 3D library : 

- Family: Hinges 
- Type: BLUM mounting plates 
- New variant: CLIP mounting plate 3mm 

 Define the set: 

- Designation: CLIP mounting plate 3mm 
- Reference: 173l8130 
- Supplier: Blum 

 Make layer 1 current. 
 

 Define the document's absolute coordinate system as a key point using the Assembly > Define component > 
Define key points function, and then select the coordinate system. 

 Create the tools of the mounting plate in the same way that you did for the previous mounting plate: 

- First create the supporting part. 
- Then create two blind holes with the following values: Diameter = 5mm, Depth = 12mm and Bottom 

angle = 0°. 
- Finally, define these drillings as component tools. 

  



TopSolid'Wood: Creation of a door  Creation of a hinge component 

Missler Software   5 

Note: In this 3mm thick mounting plate model, the auxiliary coordinate system will be created based on the 
absolute coordinate system with the same rotation as before, and a translation of 3mm. 

 Launch the Tools > Coordinate system > Wizard = Yes function. 

 Select the absolute coordinate system. 

 Click on the Advanced options button.  

 Select Transformation: Composite. 

 Transformation number 1: 

- Rotation 
- Axis: Y- 
- Rotation angle: 90° 

 Transformation number 2: 

- Translation 
- Direction: X+ 
- Translation distance: 3mm 

 Click on Stop to generate the coordinate system.  

 Define the created coordinate system as an auxiliary element using the Assembly > Define component > 
Define auxiliary elements function. 

- Name of the auxiliary element: cs1 
- Designation of the auxiliary element: Hinge positioning on the cabinet side 

 
Note: Give the auxiliary coordinate systems the same name so that the two mounting plates can be interchanged 
properly. 

 Save and close the file. 
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Creation of the mounted hinge 

Insertion of subcomponents 

 Create a new Design document. 

 Include the standard component BLUM arm > Overlay door 110°. 

 Select the absolute coordinate system of the new document as the 
destination coordinate system. 

 Repeat the procedure to assemble the hinge's 3mm mounting plate. 
 
 
 
 
 
Note: In general, when assembling hardware parts provided by manufacturers, positioning the elements absolute 
coordinate system on absolute coordinate system enables them to be exactly positioned relative to each other. 
However, in some cases you may have to create a duplicate coordinate system of the absolute coordinate system 
with a translation on Z and X in order to correctly position the mounting plate in relation to the arm. These offset 
distances are usually specified in the technical documentation of hardware components. 

 Save the mounted hinge in the training library: 

- Family: Hinges 
- New type: Mounted BLUM hinges 
- New variant: Overlay hinge 

 Define the set: 

- Designation: Overlay hinge 
- Supplier: Blum 
- Assembly nature: Sub-assembly 

Creation of the hinge's key point 

Note: The key point of the hinge will be created from the auxiliary coordinate system of the mounting plate. It is 
necessary to first display the auxiliary coordinate system of the mounting plate. 

 Launch the Modify element function.  

 Select the mounting plate. 

 Click on the Auxiliary elements button.  

 Select Hinge positioning on the cabinet side from the drop-down list in order to display the auxiliary 
coordinate system of the mounting plate. 

 

 Launch the Assembly > Define component > Define key points function and select the auxiliary coordinate 
system inherited from the mounting plate. 

- Name of the key coordinate system: cs1 
- Validate the designation of the key coordinate system. 
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Creation of the overlay parameter 

Note: An overlay parameter will be created in the hinge, which will subsequently allow you to select the right 
mounting plate according to its value. 

 Create the following parameter: 

- Unit type: Length 
- Value: 17 
- Name: o 
- Designation: Overlay 

 Define this parameter as a driver. 

 Modify this parameter and open the advanced parameters.  

 Click on the Minimum possible value button.  

 Select the Value mode, enter a value of 11mm, and then validate by pressing Enter on your keyboard. 

 

 Repeat this to define a maximum possible value of 18mm. 

The minimal and maximal values then appear between brackets after the parameter. 

 

Interchanging the mounting plate according to the overlay parameter 

Note: In order to choose the mounting plate according to the overlay parameter value, a tabulated text will be 
created. This text, which chooses the variant in the library, will vary depending on the overlay value. 
First, you need to retrieve the name of the mounting plate in the library in order to adjust it in the tabulated text. 
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Recovering the full name of the mounting plate in the library 

In order to select the correct mounting plate in the library, you must enter the component's full name exactly as it 
appears in the library. To avoid errors, this name will be recovered using a tabulated text. 

 Launch the Tools > Text function. 

 Click on the Advanced parameters button  and select Formatted text.  

 Select Template document path from the drop-down list of properties. 

 

 Then select the hinge's mounting plate as the reference element. 

 Position the text in the graphics area. 

 

 Basify this text using the Edit > Break associativity function in order to recover its value. 

 

 Launch the Modify element function and select the basified text. 

 In the window that opens, select the text value and copy it using the shortcut keys Ctrl+C. 

 Exit this window. 

Creation of the tabulated text 

 Create the tabulated text using the Tools > Text > Advanced parameters  > Tabulated text  
function. 

 Enter Reference parameter: o. 

 In the Tabulated strings window that appears, double-click in the first cell of the Reference value = o column. 

 Enter 14 and validate by pressing Enter. 

 Double-click in the first cell of the String column corresponding to the 14 value, and then paste the previously 
copied text using the shortcut keys Ctrl+V. 

 Double-click in the second cell of the String column corresponding to the > value, and then paste the 
previously copied text using the shortcut keys Ctrl+V. 

 Modify this text by changing CLIP mounting plate 3mm to CLIP mounting plate 0mm. 

 

 Validate the window with OK, and then place this text in the graphics area. 

 Delete the basified and formatted text that was previously created.  
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Interchanging the mounting plate according to the tabulated text 

The next step is the configuration of the mounting plate subcomponent so it can be interchanged automatically 
according to the tabulated text value. 

 Launch the Assembly > Define component > Define sub-component function.  

 Select the mounting plate as the component. 

 Enter Name = Mounting plate. 

 In the Sub-component definition window that opens, check the Variant option. 

 Validate the window with OK. 

 Finally, select the tabulated text from the graphics area as the text which gives the variant. 

 

The mounting plate is then selected according to the tabulated text which is adjusted to the overlay value. 
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Creation of the door 

Creation of the driver block component 

 Create a new Design document. 

 Create a driver block using the Assembly > Define component > Define drivers > Driver block function. 

  

 Adjust Default housing mode = Housing. 

 Save this file in the library : 

- Standard: My 3D Standard 
- New family: Cabinet fitting 
- New type: Doors 
- New variant: Right overlay door 

Note: In this exercise, a right door will be created. However, it is possible, using additional parameters, to create a 
single component with a left door/right door parameter. 

 Create the following parameters. 
 

Value Name Designation 

17 too Top overlay 

17 boo Bottom overlay 

17 rio Right overlay 

17 leo Left overlay 

19 th Door thickness 

70 hd Hinge distance 

 Define these parameters as drivers. 
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Creation of the door and the supporting sides 

 From the layer tree, name the layer 0 to Driver block. 

 Set layer 1 as current and name it to Supporting sides. 

 Using the Constrained block function, create the two supporting sides 

outside the driver block with a thickness of 19mm.  
 
 
 
 
 
 
 
 
 
 
 

 Make layer 2 current and name it to Door panel. 

 Hide layer 1 and create the door panel using the Constrained block 
function. 

- Thickness: th 
- First shift: -too First plane: Top face of the driver block 
- Second shift: -boo Second plane: Bottom face of the driver block 
- Third shift: -rio Third plane: Right face of the driver block 
- Fourth shift: -leo Fourth plane: Left face of the driver block 
- Positioning plane: Front face of the driver block 
- Positioning shift: 1.5mm 
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Insertion of the repeated hinges 

Creation of a parameter for the number of hinges based on the door height 

 Create a new parameter using the Parameter > Create function. 

 Adjust Unit type = No unit and click on the Tabulated values button. 

Note: The Unit type = No unit mode will create a parameter that enables a quantity to vary. Here, this parameter 
will be used to vary the quantity of hinges on the door. 
A parameter with tabulated values modifies the value of a parameter according to the value of another 
parameter. Here, the number of hinges will vary depending on the door height. 

 Specify the height of the driver block on Z (generally db.z) as the reference 
parameter. 

 
The Tabulated values window opens. 

 Create the different lines by entering the reference values of db.z 
and the values as shown opposite. 
The result is the following, with the door height as the reference: 

- from 0 to 650mm => 2 hinges 
- from 650 to 1100mm => 3 hinges 
- from 1100 to 1900mm => 4 hinges 
- beyond 1900mm => 5 hinges 

 Validate the window with OK. 

 Enter: 

- Name: hq 
- Designation: Hinge quantity 

Insertion of hinges 

 Make layer 3 current and name it to Hinges. 

 Hide layer 0 and display layer 1. 

 Include the mounted hinge using the Assembly > Include standard function. 
 
The overlay parameter is required when the component is included. As this door is a right door, the hinge's 
overlay corresponds to the door's left overlay. 

 Select the leo/Left overlay parameter from the drop-down list. 
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 Select the inner face of the left-hand supporting side as the destination coordinate system. 

 Select the top face of the supporting side as the first alignment face or edge, and then enter Distance: hd. 

 Select the front edge of the supporting side as the second alignment face or edge, and then enter 
Distance: 37mm. 

 Select the Repeat option.  

 Adjust the following options: 

- Propagation: Linear 
- Direction: Z- 
- Total distance: db.z-(2*hd) 
- Total number: hq 

 Select the Automatic option to create the drillings of the elements. 

Insertion of an optional additional hinge 

Note: On some door models, an additional hinge is added to the top of the door as reinforcement. This additional 
hinge can be added by the user by setting a parameter, or automatically according to the door width. 
These two procedures are described below. 

Insertion of the additional hinge 

 Include the mounted hinge using the Assembly > Include standard function. 

 Adjust Overlay: leo/Left overlay by selecting this parameter from the drop-down list. 
 

 Select the inner face of the left-hand supporting side as the 
destination coordinate system. 

 Select the top face of the supporting side as the first alignment 
face or edge, and then enter Distance: hd+100mm. 

 Select the front edge of the supporting side as the second 
alignment face or edge, and then enter Distance: 37mm. 

 Click on Stop in order not to repeat the hinge, and then click on 
Automatic to trigger the processes. 

 
 
 
 
 
 
 
 
Note: For now, the hinge is present in all cases. It should then be disabled when it is not needed. 
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Deactivation of the hinge according to a driver parameter 

 Create the following parameter: 

- Unit type: No unit 
- Value: 1 
- Name: ah 
- Designation: Additional hinge? 

 Define this parameter as a Boolean parameter. 

 
 
Note: A Boolean parameter is a parameter in which the only two possible values are Yes and No. 
When set to Yes, the parameter has the value 1 and 0 when it is set to No. 
This type of parameter can be used to configure a choice in a component such as, for example, whether an 
optional element is present or not. 

 Click on the Main set tab from the history tree. 

 Right-click on the line corresponding to the additional hinge 
(unrepeated Overlay hinge) and select Activation/Deactivation. 

 Adjust Deactivate = Yes. 
 
 
 
 
 
 
 

Note: The Condition field allows you to specify in which cases you want the component to be disabled. 
Here, the additional hinge must be disabled when the Additional hinge? parameter is set to No, or when the 
parameter ah==1. 

 Enter ah==0 in the Condition field, and then validate by pressing Enter. 

 

 Validate the component deactivation with OK. 

Note: The component is still displayed in the document in which it was inserted and then deactivated. However, it 
will no longer be visible in the assembly. 
In all cases, the deactivated component is no longer displayed in the bill of material and the related processes are 
not performed anymore. 
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Deactivation of the hinge according to the door width 

 Click on the Main set tab from the history tree. 

 Right-click on the line corresponding to the additional hinge 
(unrepeated Overlay hinge) and select Activation/Deactivation. 

 Adjust Deactivate = Yes. 
 
 
 
 
 
 
 
 
Note: The Condition field allows you to specify in which cases you want the component to be disabled. 
Here, the additional hinge must be disabled when the door width is less than 600mm. 

 Enter (db.x+rio+leo)<600mm in the Condition field, and then validate by pressing Enter. 

 Validate the component deactivation with OK. 

Note: The component is still displayed in the document in which it was inserted and then deactivated. However, it 
will no longer be visible in the assembly. 
In all cases, the deactivated component is no longer displayed in the bill of material and the related processes are 
not performed anymore. 
 

 
 

 

Definition of elements 

If the door panel is always a simple part or a panel with edges and/or laminates, then the part can be defined 
directly in this document. 
If the type of door panel is bound to change with subcomponents (next exercise), the door panel that was drawn 
will be used as a construction volume for these subcomponents; it must not be defined. 

 If necessary, define the door panel. 

 Define the set: 

- Designation: Right overlay door 
- Assembly nature: Sub-assembly 
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Creation of door panel subcomponents 

Note: Subcomponents will be created in order to be included as subcomponents of the door. Consequently, once 
the door has been included in an assembly, you can choose the type of door panel you want. 
In addition, as each door panel subcomponent is designed differently, each of them can have different drivers. 
For example, for the Wood and mirror panel, only the crosspiece widths can be driven, while for the Grooved 
panel both the groove offset and the groove width can be driven. 
 
 

Wood and mirror panel Grooved panel Simple panel 

   

- Crosspiece width parameter 
- Groove offset 
- Groove width 
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Creation of subcomponents 

Creation of the Wood and mirror panel 

 Create a new Design document. 

 Create a driver block using the Assembly > Define component > Define drivers > Driver block function. 

 Adjust the default dimensions of the driver block:  

- X length: 600mm 
- Y length: 19mm 
- Z length: 860mm 

 Select Default housing mode = Inside a block. 

 

 Save this file in the library : 

- Standard: My 3D Standard 
- Family: Cabinet fitting 
- New type: Door panels 
- New variant: Wood and mirror panel 

 Create the following parameter: 

- Value: 80mm 
- Name: cw 
- Designation: Crosspiece width 

 Define this parameter as a driver. When defining the parameter as a driver, enable the Secondary driver 
option. 

 
 
Note: In the case of subcomponents, the secondary drivers allow you to create specific parameters for each 
subcomponent. Consequently, these parameters will be available when the subcomponent is modified at one or 
more assembly levels. 

 Make layer 1 current. 

 Using the Constrained block function, draw the two jambs 
and the two crosspieces of the panel: 

- Thickness: db.y 
- Width: cw 

 Position these four parts inside the driver block. 

 Use the Constrained block function to create the mirror: 

- Thickness: 8mm 
- The mirror goes inside the crosspieces by 10mm 
- Positioning shift: db.y/2 
- Positioning plane: Front face of the driver block 

 Groove the parts: 

- Tool type: Saws 
- Parameters: Centred 
- Gap distance: db.y/2 
- Groove width: 8mm 
- Groove depth: 11mm 
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 Define the four supports of the panel: 

- Designation: Left jamb / Right jamb / Top crosspiece / Bottom crosspiece 
- Material: TopSolid'Wood > Hardwoods > Alder 

 Define the mirror: 

- Designation: Mirror 
- Material: TopSolid'Wood > Glasses > Mirror 

 Define the set: 

- Designation: Wood and mirror panel 
- Assembly nature: Sub-assembly 

 Save and close this file. 
 
 
 

Creation of the grooved panel 

 Create a new Design document and create a driver block in the same way as before. 

 Save this file in the library : 

- Standard: My 3D Standard 
- Family: Cabinet fitting 
- Type: Door panels 
- New variant: Grooved panel 

 Create the following two parameters: 
 

Value Name Designation 

80 go Groove offset 

10 gw Groove width 

 Define these parameters as secondary drivers. 

 Make layer 1 current. 

 Using the Constrained Block function, create the door panel with a thickness = db.y. 

 Position this part inside the driver block. 
  



TopSolid'Wood: Creation of a door  Creation of door panel subcomponents 

Missler Software   19 

 Create a sketch on this part as shown here. 

 Then use this sketch to groove the panel: 

- Tool type: Routers 
- Groove mill 
- Parameters: Centred 
- Gap distance: 0mm 
- Groove width: gw 
- Groove depth: 10mm 

 Define the panel: 

- Designation: Grooved panel 
- Material: TopSolid'Wood > Panels > 

Colors > White 

 Save and close this file. 
 
 
 
 
 
 
 
 
 

Creation of the simple panel 

 Repeat the previous steps to create a third panel subcomponent: 

- No parameters 
- Panel using a constrained block with a thickness of db.y 

 Create the chamfer on the panel: 

- Use the Shape > Chamfer function  
- Length: 2mm 
- Select the Shape mode to apply the chamfer on all the 

panel's edges automatically 

 Define the panel: 

- Designation: Simple panel 
- Material: TopSolid'Wood > Panels > Colors > White 

 Save this file in the library : 

- Standard: My 3D Standard 
- Family: Cabinet fitting 
- Type: Door panels 
- New variant: Simple panel 
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Configuration of subcomponents 

Insertion of subcomponents 

 Edit the Right overlay door component. 

 Make layer 4 current. 

 Insert the Wood and mirror panel component. 

 For the driver block, select the building block of the door on 
layer 2. 

 Validate the default parameter values. 

 Hide layer 2. 
 
 
 
 
 
 
 
Note: When hinges were included, the Automatic option was used in order to 
create the associated machinings. However, the parts to operate have just been 
inserted (door panel). The file needs to be regenerated so that the hinges can 
operate the door. 

 Launch the File > Regenerate function.  

 Click on This document.  
 
Note: If the door is not drilled after the file is regenerated, it means the 
Automatic option was not used when the hinges were included. 
However, it is still possible to enable it using the Assembly > Use process > 
Select the hinge > Automatic function. 

Definition of subcomponents 

Note: To modify the type of door panel once the door is included in a project, it must be defined as a 
subcomponent. 

 Launch the Assembly > Define component > Define sub-component  function. 

 Select the door panel as the component. 

 Enter Name = Panel. 

 From the Sub-component definition window that appears, check the Variant option. 

 Validate the window with OK. 

 Finally, validate the dialog box by clicking on Stop.  

 Save and close this file. 
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Using the door 

 Open the provided file called Storage cabinet.top. 

 Include the Right overlay door component in some of the cabinet's compartments. 

 Adjust the top and bottom overlay parameters to 8.5mm. 

 Leave the left and right overlay parameters to their default values of 17mm. 

 Use the Automatic option to create the drillings of the mounting plates in the storage cabinet. 

 

 Launch the Modify element function and select the panel of one of the included doors.  

 Select the Sub-component option.  
 
Note: If some elements of a component are defined as subcomponents, this option is then available when 
modifying the component included in an assembly. 
This option lets you make changes to the component such as the secondary drivers, and lets you modify its code 
and/or variant depending on what settings you made in the subcomponent definition. 
 
In the Choice of sub-components to modify window, the elements of the component being modified are 
displayed. The editable elements defined as subcomponents are displayed in bold and can be selected. 
Once a subcomponent is selected, the following three options are available: 

- Interchange: Allows you to modify the code and/or the variant of the subcomponent. 
- Parameters: Allows you to modify the secondary drivers of the subcomponent. 
- Cancel: Allows you to exit the function. 
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 Select the Wood and mirror panel subcomponent. 

 Click on the Interchange button. 

 Select the Grooved panel subcomponent, and then validate with OK. 
 
Note: Once a subcomponent has been interchanged, an option in the dialog bar asks whether you want to change 
all the other identical subcomponents of the document automatically. 

 

 Click on No in order not to change the other door panels. 

Finally, you can modify the secondary parameters of the subcomponent in the dialog bar, if necessary. 

 Adjust the groove width to 20mm. 
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